Contact Manager Slowness & List Loading Errors
Incident Report for SharpSpring
Resolved
This incident has been resolved.
Posted Jul 15, 2024 - 16:13 EDT
Monitoring
Our team has released an update and is monitoring improved performance within the contact manager and lists for all accounts.

Our team is continuing to monitor the release to ensure performance of contacts and lists is fully restored.
Posted Jul 15, 2024 - 15:01 EDT
Investigating
Our team has received reports that some customers are experiencing slowness within the contact manager. Some customers have also reported receiving 502 loading errors when attempting to open lists.

Our team is aware of these reports and investigating them. We will share updates to this page as they become available.
Posted Jul 15, 2024 - 13:32 EDT
This incident affected: Contacts/Leads (Contact Manager) and Lists and Segmentation (List Building).