We are seeing everything having returned to normal and the final automation events clear as of 11:20pm EST last night. Thank you for your patience.
Posted Jul 08, 2026 - 08:28 EDT
Monitoring
We have seen sustained improvements to the performance across the app and will continue to monitor. Automations are returning to normal. We will apply more updates as they become available.
Posted Jul 07, 2026 - 18:11 EDT
Update
*Adding note that this behavior is affecting Automations but overall App Performance, including page loading and login. Updated title to encompass all behaviors. We are continuing our research into this behavior and while we are seeing improved performance we are ensuring that our adjustments are improving all areas equally.
Posted Jul 07, 2026 - 16:53 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 07, 2026 - 15:21 EDT
Monitoring
This behavior should be resolving and we will continue to monitor to ensure a smooth return.
Posted Jul 07, 2026 - 12:44 EDT
Identified
Some customers may be experiencing automation delays today. We are already seeing successes of this resolving however please reach out to Support if you have any questions.