General Performance Issues Across the Application

Incident Report for SharpSpring

Resolved

Our team has continued monitoring the platform and confirmed that all systems are now operating normally.

If you continue to experience any issues within the platform, please reach out to Support for assistance.
Posted Aug 29, 2025 - 15:53 EDT

Monitoring

Our team have restored the application and are monitoring current performance. At this time, some users may still see slight delays loading certain pages, such as the contact manager or email editor.

Our team will continue monitoring performance of the site. We will provide further updates to this status page.
Posted Aug 29, 2025 - 14:40 EDT

Identified

Our team have identified an issue impacting some accounts that may cause general performance issues using several areas of the platform. Our team is aware of the root cause and working to restore full functionality for all users as quickly as possible.

We will update this status page with more information as soon as it is available.
Posted Aug 29, 2025 - 13:11 EDT
This incident affected: SharpSpring Application.