Slowness on the Platform

Incident Report for SharpSpring

Resolved

Our team has confirmed the slowness issues reported earlier have been resolved. We are closing out this incident.

Please reach out to support if you continue to experience any issues with the application.
Posted Jun 29, 2026 - 14:06 EDT

Monitoring

We are seeing improved responsiveness throughout the application. Our team is still monitoring results of our update. Currently, users should be able to navigate without slowness or system delays.
Posted Jun 29, 2026 - 13:09 EDT

Investigating

Customers are currently reporting slowness and lag throughout the application. As of now, every area of the application remains accessible, but some areas are loading more slowly than others.

Our team is aware of the reported slowness, and are working to improve performance to the app as soon as possible.
Posted Jun 29, 2026 - 11:35 EDT
This incident affected: SharpSpring Application.