Form Submission Processing Delays
Incident Report for SharpSpring
Resolved
This incident has been resolved.
Posted Nov 18, 2021 - 14:21 EST
Identified
Some form submissions are being delayed in processing. The issue has been identified and we are working on a solution.
Posted Nov 18, 2021 - 11:25 EST
This incident affected: Forms Delivery (Form Submissions Processing).